Zend Studio debugger doesn’t work on Magento


Learning Magento is hard enough and when you’re debugger won’t stop at any breakpoints, that’s enough to take any developer out of his game. I was fortunate to find this blog post http://rocinantesoftware.blogspot.com/2009/06/debugging-magento-vista-xampp-zend.html detailing how to configure various debuggers to work with Magento. Below is how to configure your magento project with Zend Studio for Eclipse.

ZEND STUDIO FOR ECLIPSE
The following assumes that Magento can be reached from http://127.0.0.1/magento
– From the “Run” menu, select “Debug Configurations”
– On the left, right-click on “PHP Web Page” and select “New”
– Name: Magento
– Server Debugger: Zend Debugger
– PHP Server: Click on the “New” link
– Name: Magento Server, URL http://127.0.0.1 (do NOT use localhost – I don’t have notes on this, but I’m sure that I had trouble accessing the admin area using local host, and switching to http://127.0.0.1 fixed the problem).
– Hit next, going to the Server Path Mapping, and “Add”
– Path on Server: the windows path to your magento dir, e.g. C:\Users\Ed\workspace\magento
– Path in Workspace: /magento
– Click Finish
– Now back in the “Debug Configurations” dialog, set file to magento/
– uncheck “Auto Generate (URL)”, and set the path (first part of which is auto-generated) to /magento
– In the “common” tab, click “run” and “debug” for showing in the favorite menus.

Also, for me personally I had to edit the php server and clear out the “Local Web Root” input and on the “path mapping” tab ensure you have one entry – the “path on server” should be the full directory path to your application and the “local path” should be the name of your zend studio project, such as “/magento”.

Leave a comment

Your email address will not be published. Required fields are marked *