Composer: Requirements could not be resolved to an installable set of packages


After cleaning out the /vendor directory and running composer install, this error “Requirements could not be resolved to an installable set of packages” appeared and the process stopped. This seems to be a common and difficult issue to resolve with composer. This post from stackoverflow has a pretty good explanation on how it could be a dependency version issue http://stackoverflow.com/questions/20996767/requirements-could-not-be-resolved-to-an-installable-set-of-packages , but that wasn’t it for me as it was just working. My composer.json file included about 20 dependencies, so I removed all but 3 and installed them successfully. Then added a few more and ran composer update and repeated this process until everything was back.

Leave a comment

Your email address will not be published. Required fields are marked *